Platform forum

Rex Kernel 4.1.15 Version

ranaya , 04-24-2017, 10:38 PM
Dear All,

Hi, do we have a REX git branch for kernel 4.1.15 ? What's the latest ?

robertferanec , 04-25-2017, 04:43 PM
@ranaya, check out the VOIPAC github: https://github.com/voipac/linux-fslc...-2.0.x-imx-rex
and also VOIPAC wiki: http://wiki.voipac.com/xwiki/bin/vie...+tinyrex/linux

I hope this helps.
ranaya , 04-25-2017, 10:16 PM
Hi, the reason I asked for kernel version 4.1.x is that, I am having troubles of getting usb cameras working on rex 3.1.14.x kernel. I can confirm that camera is available as a video device through v4l2-ctl command. When I run the gstreamer pipeline, 'internal data flow error' pops up and pipeline gets paused. Even i can see that camera has been correctly identified by UVC class. The result is same for different USB cameras for custom yocto build as well as for the prebuilt image comes with sd card. I am using Open Rex SBC (IMX6Q) platform. What might be the root cause of this ?

Or should I open a new thread for this ?
robertferanec , 04-26-2017, 01:22 PM
I am not a software guy, but I know in some specific kernels there was a problem related to the kernel source code changes / possibly file system. I remember your other threat about ADV7611. Did you make it work?
ranaya , 04-26-2017, 09:03 PM
Hi thanks for your reply. Well I was able to get the adv7611 to its free run mode. But through 8-bit BT656 interface. I guess 16 bit mode should also work, I am waiting till our custom board comes.

Have you got the USB cameras working on open Rex for the kernel version I mentioned ? Even though 3.1.14 is bit older, the USB cameras should work without any problem. Anyway can we use the zImage of kernel 4.1.x with the sd card having kernel 3.14.x zImage ? in otherwords how can we utilize kernel 4.1.x with yocto environment inside fsl-community-bsp project folder ?
ranaya , 04-26-2017, 09:36 PM
Or... how this add support layer should be modified for 4.1.x krogoth ?
cat > .repo/local_manifests/imx6openrex.xml << EOF
<?xml version="1.0" encoding="UTF-8"?>

<remote fetch="git://github.com/FEDEVEL" name="fedevel"/>

<project remote="fedevel" revision="jethro" name="meta-openrex" path="sources/meta-openrex">
<copyfile src="openrex-setup.sh" dest="openrex-setup.sh"/>
Or can I use the steps given in following page (However this is for tinyrex):

robertferanec , 04-27-2017, 08:16 AM
- we have not tried any USB cameras, only Raspberry Pi
- you can follow VOIPAC wiki
ranaya , 04-28-2017, 03:29 AM
I followed the steps under yocto. But I cannot get the system up for the SD card image i created (board seems to be running, but no hdmi signal output). I can clearly see that the boot partition and rootfs partition having the files accordingly. After I replaced the openrex-max.dtb file with the original dtb file that comes inside pre-built image, the hdmi display got the signal, but leaving a black screen. Nothing is shown........ Could this be due to a change in 4.1.1x kernel ?

robertferanec , 04-28-2017, 11:32 AM
I wish I could help you. Honestly, I do not know VOIPAC does a lot of software for all the REX boards. If you bought the board through them, you can try to ask some questions directly there. They may be able to help.

If you figure it out, please share your solution with others. Thank you very much.
Use our interactive Discord forum to reply or ask new questions.
Discord invite
Discord forum link (after invitation)

Didn't find what you were looking for?