Platform forum

Setting up YOCTO for iMX6 Rex

paul_aldana , 10-20-2016, 09:25 AM
Good day,

I'm trying to install YOCTO into my host computer by following the steps provided in this guide: http://www.imx6rex.com/software/how-...rt-with-yocto/

Unfortunately, I'm having problems with the bitbake part of the "Compile your first uBoot & Kernel from YOCTO". I'm attaching the screenshot of the errors I got after running the bitbake command.

Do you know how to work around this problem?


robertferanec , 10-20-2016, 11:12 AM
What Linux version did you use?
robertferanec , 10-20-2016, 11:16 AM
BTW: there is a lot of documentation for OpenRex, it is very similar for iMX6 Rex, have a look: http://www.imx6rex.com/open-rex/openrex-content/
paul_aldana , 10-20-2016, 03:27 PM
I used Ubuntu 12.04 just like in the guide I posted.
robertferanec , 10-20-2016, 03:29 PM
Try to run the bitbake again. It looks to me like it could not download the one file ... when you try to run the bitbake command again, it may just work.
paul_aldana , 10-20-2016, 05:24 PM
I tried the bitbake again and I got an error (see picture).

robertferanec , 10-20-2016, 05:29 PM
Try it multiple times. Normally it should go through without problems, but it looks like in your case there may be a problem with internet connection (?). Try it until it will download all the files.
paul_aldana , 10-26-2016, 09:18 AM
Okay, so I tried following this http://www.imx6rex.com/open-rex/soft...ine-for-yocto/ which is Ubuntu 14.04.4 and still the same result. I followed every step and still no luck
robertferanec , 10-26-2016, 09:33 AM
You have to keep re-running the bitbake command. It looks like you have something with internet connection.
CBG , 03-21-2017, 12:51 AM
I have got a similar issue just recently when I tried to setup the VM for OpenRex project.
I have attached a picture with the error messages that popped up.
Please advise what to do from here.

I look forward to receiving your advice.
Use our interactive Discord forum to reply or ask new questions.
Discord invite
Discord forum link (after invitation)

Didn't find what you were looking for?