Platform forum

Writing to SPI Flash

dcmccall , 04-23-2020, 02:28 PM
Hey everyone!
I received my imx6rex a few days ago and was able to get it to boot from the SD card using instructions from the first two videos of Robert's course.

After getting it to boot, for some reason, I got the urge to try to flash a newer version of uboot into spi flash and that's when I ran into some trouble.

I followed the directions here https://www.imx6rex.com/open-rex/sof...h-update-boot/ and ran into what seems to be the usual trouble of sf probe not finding 3:2, so I removed the bus and chip select and got that to run, what seems to be properly.

The problem I'm having now is that it seems to do everything successfully, but once the device is restarted I am getting no output on the serial terminal. I have been successfully using the uboot image that I compiled during Lesson 2 to get things going using the MFG tool, and am still able to boot into Linux.

I have tried every combination of flashing the spi flash with and without the boot select jumper, with and without saving environment variables(saveenv comments that it's erasing spi flash, so I added this in to variables to try), as well as using the uboot files ending in .bin and .imx from my build, one or two from voipac's git repository, and the one ending in 2G from the aforementioned instructions.

There has to be something silly that I'm missing here since all of these boot images are working perfectly fine as sources for the MFG tool. Hopefully one of you can help!

Thank you much!
robertferanec , 04-24-2020, 05:33 AM
You do not see any output, but board is still booting up? Or board is not even booting up?
dcmccall , 04-24-2020, 08:22 AM
I'm only able to get it to boot with the MFG tool. Without that it isn't booting up.
robertferanec , 04-27-2020, 05:18 AM
If you are able to boot up (even if it is MFG only), that it is very good. Boot up from MFG and re-flash the SPI. Just try to do it until you do not figure out what is wrong. First try to reflash working images (e.g. maybe download something from voipac wiki website) and once these work, try to reflash with your own image.

Please, let me know when you make it work.
dcmccall , 05-01-2020, 03:55 AM
I was able to flash an image that worked!

I downloaded a pre-compiled u-boot image from voipac's website and following the commands under Log - SPI here http://wiki.voipac.com/xwiki/bin/vie...+openrex/uboot

Thank you much!
robertferanec , 05-05-2020, 09:41 AM
Use our interactive Discord forum to reply or ask new questions.
Discord invite
Discord forum link (after invitation)

Didn't find what you were looking for?