Platform forum

Lesson2: python 2 no longer supported error

meera , 04-02-2023, 11:56 AM
After deleting fsl-community-bsp directory, followed steps in openrex->how to startwith software, lesson2; please find 2 snapshorts attached. error is related to 1.59th minute, where I execute the repo init command, what is the workaround for this? Thank you.
dodoolas , 04-03-2023, 05:15 AM
Hello @meera,

I tried the first 2 lessons step by step just a week ago and it worked for me. Please, have a look at this document:

I ran into a similar issue as you describe at the beginning of lesson 2. Right away, I tried the very same fix that worked in the first lesson, however it did not work for lesson 2 for the first time.

I rebooted the virtual machine and I tried to fix the Python version issue with the very same command lines from the earlier again:
cd ~
mkdir ~/bin
git clone https://gerrit.googlesource.com/git-repo
cd git-repo
git checkout 27da4ddeb9159573e0207f71e4d9b3ae286b5275
cp repo ../bin
chmod a+x ~/bin/repo

Re-entering the repo command lines:
mkdir fsl-community-bsp
cd fsl-community-bsp
repo init -u https://github.com/Freescale/fsl-community-bsp-platform -b jethro

It worked! Please try to reboot your virtual machine, follow the instructions again and let me know if it works for you as well.

Thank you​
meera , 04-03-2023, 09:27 AM
It worked for me too. Thank you
meera , 04-03-2023, 10:58 AM
now am facing error after repo sync command. Please find snapshorts attached.
robertferanec , 04-03-2023, 11:06 AM
Maybe try later again? This could be internet problem (?)
dodoolas , 04-03-2023, 02:12 PM
Hello @meera,

Could you please confirm if you can access the document below? This document describes situations you may run into that are not shown in the course video:

Thank you​
meera , 04-05-2023, 10:24 AM
yes, am able to access the document from above link.
dodoolas , 04-05-2023, 05:06 PM
Originally posted by meera
yes, am able to access the document from above link.

If you have look at L2: 00:03:24 section in the previously attached document, you will find the notes about this topic and also about some other issues you may run into:

When trying to download the files with command:
repo sync

I got the very same error as you do:
Fetching projects: 87% (7/8) pokyfatal: unable to connect to github.com:
github.com[0:]: errno=Connection timed out

fatal: unable to connect to github.com:
github.com[0:]: errno=Connection timed out

error: Cannot fetch meta-openrex from git://github.com/FEDEVEL/meta-openrex
Fetching projects: 100% (8/8), done.
error: Cannot checkout meta-openrex: ManifestInvalidRevisionError: revision jethro in meta-openrex not found
error: in `sync`: revision jethro in meta-openrex not found

The problem was the git port is restricted (https://github.com/npm/npm/issues/6285). Fixed this with following command:
git config --global url.https://github.com/.insteadOf git://github.com/

The second attempt of downloading (rest of the) files with:
repo sync

It worked out:
fedevel@fedevel-VirtualBox:~/fsl-community-bsp$ repo sync

... A new repo command ( 1.27) is available.
... You should upgrade soon:
cp /home/fedevel/fsl-community-bsp/.repo/repo/repo /home/fedevel/bin/repo

Fetching projects: 75% (6/8) meta-fsl-armremote: Enumerating objects: 160, done.
remote: Total 160 (delta 0), reused 0 (delta 0), pack-reused 160
Receiving objects: 100% (160/160), 58.64 KiB | 0 bytes/s, done.
Resolving deltas: 100% (68/68), done.
From https://github.com/FEDEVEL/meta-openrex
* [new branch] jethro -> fedevel/jethro
* [new branch] master -> fedevel/master
Fetching projects: 100% (8/8), done.
meera , 04-07-2023, 05:33 AM
today I have been trying the above fix for repo-sync. I directly followed the steps given in "L1-L2 process double checked" page. It still doesnt work, the same "pokyfatal" error I got. Th solution, I found by in net and it is the following. In the openrex-> how to start with software page, in
cat > .repo/local_manifests/imx6openrex.xml << EOF

<?xml version="1.0" encoding="UTF-8"?>


<remote fetch="git://github.com/FEDEVEL" name="fedevel"/>

<project remote="fedevel" revision="jethro" name="meta-openrex" path="sources/meta-openrex">

<copyfile src="openrex-setup.sh" dest="openrex-setup.sh"/>




instead of using <remote fetch="git://github.com/FEDEVEL" name="fedevel"/>, use <remote fetch="https://github.com/FEDEVEL" name="fedevel"/>,
after that it worked. PFA snapsots (the solvedpoky snapshot).
meera , 04-07-2023, 05:35 AM
OK. I have just seen your post, after I posted. I was looking at the https://docs.google.com/document/d/1...kjFXXQXg/edit#. Thank you
meera , 04-07-2023, 07:24 AM
This is a query in Lesson 2, at around 4.48 minutes. When you say " your board needs to be similar to the reference board", what it means? I have a situation, where I have two reference boards (board1 & board2), both having cortex-a9 core based processor from 2 different manufacturers. the third board is the board on which I need to port uboot, it has processor from the second board and other hardware from the first board. how should i proceed with developing uboot for the third board. Thanks
meera , 04-07-2023, 08:10 AM
continuing towards bit command. pfa snapshots, bitbake failed. I am trying for solution from my end too.
robertferanec , 04-11-2023, 01:43 AM
@meera is it working now?
Use our interactive Discord forum to reply or ask new questions.
Discord invite
Discord forum link (after invitation)

Didn't find what you were looking for?