Platform forum

Question related to Lesson1: Learning essentials of creating UBoot, Linux and Yocto

meera , 02-21-2023, 07:28 AM
I got the following error, when I gave the command, "repo init -u https://github....jethro", error: repo: error: python 2 is no longer suppported, please upgrade to python 3.5+. As a result, I am unable to download original sabresd source code itself. Please resolve. Thank you.
robertferanec , 02-21-2023, 07:39 AM
On the course page, there is a TAB called Questions & Updates. Please follow the instructions there, they should help.
meera , 03-03-2023, 08:13 PM
Thank you.
meera , 03-03-2023, 08:15 PM
Hello Sir, Virtual box 5,1,6 is not supported in Windows 10. Which version of virtual box to use, so that compilation of uboot using ubuntu 14.04 goes through without any hasseles.Thank you
robertferanec , 03-04-2023, 12:55 AM
You can use the latest Virtual box, that should not be a problem.
meera , 03-05-2023, 06:04 AM
I am unable to successfully go beyond, " sudo apt-get install xinetd tftpd tftp​". I tried twice and could not get past the above command. (I have installed Ubuntu 14.04 LTS on a windows machine in dual boot mode) First time, wifi was disconnected and it took me quite sometime to download the relevant drivers and get wifi working. Yesterday, I again tried all the commands given in Lesson#1, "How to prepare a host machine for yocto". ALso before giving the above command, I checked which xinetd tftpd tftp, except tftpd, it showed the other two. After that I gave the sudo apt-get install xinetd tftpd tftp command, it took some time and after the command there was an error message, after which the system was hanging and when I tried reboot, the system went into kernel panic mode and I am unable to re-install ubuntu 14.04, until now. Any suggestions/ solutions, as I am unable to do the actual Uboot code modfication and compilation. I am trying it with virtual box too, but not able to progress.
robertferanec , 03-05-2023, 06:57 AM
Please, could you attach terminal outputs?
meera , 03-05-2023, 09:48 AM
Immediately the system was hanging and then there was a booting problem, it got into kernel panic mode, so I do not have any snapshot. We are still working on repairing ubuntu, so that we can boot normally.
robertferanec , 03-06-2023, 03:26 AM
hmm, this looks to me more like OS problem, rather than tftp installation problem.
what problems do you have with the virtual box? did you enable virtualization in BIOS?
Use our interactive Discord forum to reply or ask new questions.
Discord invite
Discord forum link (after invitation)

Didn't find what you were looking for?