Platform forum

Problem with moving components on PCB because of assembly drawings

info@ewtech.de , 05-14-2018, 12:52 PM
during a layout, I noticed a problem with moving components on the PCB. I had only Bottom layer displayed buy while selecting a component, I noticed it is bigger than the component's footprint as shown in the attached screenshot. I investigated in my PCB library to see if there is a problem with the footprint. There I noticed the assembly drawing of the component. I enabled all layers to see if that is it, and yes, it was the designator of the component in the assembly drawing. So I had to place the designator in the middle of the component in mechanical layer 29, where I have defined my assembly drawings. By doing this, I could move the component freely between all other components on the PCB.
Is there a way to ignore all designators in any layer during placement?

mairomaster , 05-15-2018, 01:53 AM
Unfortunately, with Altium all the primitives in the footprint determine the bounding rectangle, which is used for clearance. You can try disabling the online/batch version of the component clearance from the design rule check window. Also it might help to have the special string replacement turned on, so that the designator string gets replaced by the actual designator which is shorter in terms as symbols, hence less long.
info@ewtech.de , 08-21-2018, 02:06 PM
I disabled online/batch version of the component clearance but it did not help and in version 18 of Altium, they say:
  • The Convert Special Strings option has been removed since the string is always displayed; if null, then the parameter name is displayed
Now the question is, what to do with this problem? I have a serious problem with placement because of this. I am doing the placement of IMX module for the advanced layout course and I need to save place by getting components closed to each other but I can't. Those components in the red area (see attached screenshot) suffer the same problem.
robertferanec , 08-23-2018, 11:26 PM
I am still not sure what the problem is. Do you get component clearance violation?
info@ewtech.de , 08-24-2018, 12:37 AM
Hi Robert,
no violation. I just can't move the components towards others when I reach a certain distance. I can send you the project as is but I don't know if it is possible to upload a zip file here in this forum. Is it?
robertferanec , 08-24-2018, 12:42 AM
ok, send it to me, please delete history directory, so the file is not large.
info@ewtech.de , 08-24-2018, 12:44 AM
OK Robert but I am at work and I can probably send it to you till tomorrow. Thanks a lot.
info@ewtech.de , 08-26-2018, 02:28 PM
Hi Robert,

sorry for the late reply. I could not upload the rar file here. I will send it to you per E-Mail.
robertferanec , 08-28-2018, 02:27 AM
I have got the file, however, there is an error (I can not open it, see below). Please could you use zip instead?

info@ewtech.de , 08-28-2018, 02:30 AM
Hi Robert,
sure I will. Thanks for your time.
robertferanec , 09-04-2018, 11:57 PM
I do not have any problems in that area (no placement problems, no selection problem):

batistalex , 03-19-2019, 07:56 AM
In Altium 19 I'm having a similar problem. Although I can edit the size of the textbox of the assembly layer when I close the Altium the problem remains. The solution of resizing the box only works until I close Altium. This is really annoying because disturbs all the placement. The original size of the box is because of the text ".Designator", Altium is replacing it by the actual designator but don't change the size of the textbox accordingly.

Did anyone find a solution for this?

robertferanec , 03-21-2019, 07:25 AM
The original size of the box is because of the text ".Designator", Altium is replacing it by the actual designator but don't change the size of the textbox accordingly.
I do not have access to altium right now to try it, but I do not think this is happening in my altium.

I do not know - maybe if you show ALL Layers, maybe something else is there - but on different layer? But I guess, you have already tried that.
batistalex , 03-29-2019, 07:29 AM
Yes @robertferanec , I tried a lot of things but I'm sure that this is the assembly layer because I measured the box in the TOP Assembly of the library and in the TOP Assembly of the PCB and it is the exact same size. Additionally, as I said when I edit the size of the box directly on the PCB every works as supposed to do, but until I restart Altium.
robertferanec , 04-01-2019, 08:34 AM
Just an idea - I had some problems with layers in AD19 (not exactly this problem, different problems) and once I installed the latest fix, everything worked properly. Are you running the latest fix? Maybe that could help?
batistalex , 04-01-2019, 10:18 AM
Originally posted by robertferanec
Are you running the latest fix? Maybe that could help?
Yes, I'm running the Altium 19.0.14 version, that is the last version available to me.
Paul van Avesaath , 04-04-2019, 02:13 PM
also you could try in altium 18 to see if you can do it there.. AD19 is still not bug free enough to use as your daily driver IMHO
batistalex , 04-04-2019, 03:09 PM
I had the same problem with Altium 18. Actually, I was hoping that in Altium 19 this problem was fixed but I was wrong
robertferanec , 04-05-2019, 10:38 AM
Maybe try to download our project from https://www.imx6rex.com open it and check out our PCB. Let me know if it is the same or if our PCB behaves differently.
batistalex , 04-05-2019, 11:13 AM
Hi, @robertferanec in the imx6rex project the problem does not appear. It is really strange, I had the same problem in a few projects using Altium 18 but in others, I hadn't. For example, I was checking the project 28pin that I made in your course last year and it seems ok.
robertferanec , 04-08-2019, 02:13 AM
Maybe try to figure out if the problem is in library or in the board .... for example maybe try to copy components from a library with no problems and place them into your project ... to see if that helps.
JohnsonMiller , 09-28-2020, 11:30 AM
In old AD, and in layer stack colour setting we had an option to control the conversion and visibility of special strings on PCBs, looks gone in AD20, am I right?
robertferanec , 09-29-2020, 07:39 AM
I have seen it always enabled in AD20 ... I am not sure if it is possible to disable the automatic special string conversion.
qdrives , 10-01-2020, 02:15 PM
Do you have the 3D model too? Altium changes the bounding box to the 3D model if there is one, and has a large box when there isn't one. 3D model could be linked, so moving to another machine may fail as the linked file does not exist.
Use our interactive Discord forum to reply or ask new questions.
Discord invite
Discord forum link (after invitation)

Didn't find what you were looking for?