Platform forum

Trouble with Assembly Drawings in Altium 23

mulfycrowh , 03-09-2023, 03:02 PM

I am trying to get the assembly drawings of my project.
I added 1 Output Job File.
Then Assembly Outputs ...
I selected A4 for the size of the pages.
I get a PDF file with page size of 188,58 x 78,79 in and the drawing doesn't fit to the page.
The board is displayed on an area of about 1/12th of the page!
I tried other settings.
Same result.

Do you have any idea?

mulfycrowh , 03-09-2023, 03:23 PM
Furthermore after publishing the PDF file is displayed with all pages blank on web page.
It is displayed with wrong scale pages with Acrobat Reader.
mulfycrowh , 03-09-2023, 04:16 PM
Sorry, the pages on web page are not blank.
The drawing only spreads over 1/12th of the page area.
mulfycrowh , 03-09-2023, 11:34 PM
What is the problem?
Is there something I do wrong?
qdrives , 03-10-2023, 01:57 PM
First of all the PDF output for assembly drawing does not export the page size (always) as configured.
The way I do it is by setting it 1:1. I do not care about page (paper) size as it is ignored anyway.

When printing with Adobe Reader you can set the "Size" (button) to "fit" (option)

This is how it is configured:

And this is the PDF result, the paper size is bigger than A3:

If you want better to scale settings, then there are 2 options:
- Use another "printer". This can also be the "microsoft print to PDF" one.
- Use a draftsman document.
mulfycrowh , 03-10-2023, 02:09 PM
@qdrives clearly speaking, Altium 23 does not export the way we want.
It was OK with AD21.
Thanks for the advice.
I am going to try ...
qdrives , 03-10-2023, 02:28 PM
I do not know if AD21 was better.
See also this discussion: https://designhelp.fedevel.com/forum...eg-print-issue
It was @robertferanec who mentioned this a long time ago. I do not know if it was here or on LinkedIn.

I always had the assembly drawing in the 'fit' mode and never checked the actual size. I even printed them on 3xA3 and tape them together in order to be able to read the designators.
For the exports where I want true 1:1 scale (ie for checking footprints) I print directly to a printer.
robertferanec , 03-14-2023, 03:31 AM
@qdrives is right, try to use different PDF printer (not Altium's default) and be sure scale is set to 100%.

This may help: https://www.youtube.com/watch?v=PqFtSpAXB9Q&t=4751s
Use our interactive Discord forum to reply or ask new questions.
Discord invite
Discord forum link (after invitation)

Didn't find what you were looking for?