Platform forum

Designator and Comment on right layer in PCB dont work properly

Tueftler , 08-14-2021, 04:38 PM
Hi there.

Greetings to these community - I'm the new one

To my question:
In Altium Designer, i have to tune my workflow a bit.
If i import the parts from the schematic to the pcb, each comment and designator will be imported to the Top Overlay layer.
Normally, i select all texts on these layer now and move it to my favorite one, the Assembly text top layer.
-> I dont want any printed designators or comments...
After each import, i have to do that - and i'm not happy with that...

In the PCB-Editor default preferences there is a possibility to define the layer for booth text, but it dont work on my PC!?

If i put a text by hand into the .pcblib with '.comment' and '.designator' , it would be display properly.
But the other naming in Top Overlay is visible, too.
So, that is not a solution, too.

Hope anybody can help me why the setting is not working properly on my AD.

Thank you in advance and have a nice Sunday!
robertferanec , 08-17-2021, 07:05 AM
I always do this at the end of design process - when PCB is almost finished. So, I only do it once.
qdrives , 08-17-2021, 01:41 PM
In AD21 they added the designator layer pairs. However, they continue to have the designators on other layers when you sync sch->pcb.
What I always do is via "PCB Filter" the "IsDesignator" command and then change the layer (AD20 and earlier) or hide them (AD21). When changing layers also set position to center and 0.8mm height.
Yes, it may be required each time new components are added.
Hopefully, AD22 will be better, like when selecting "Add designators for assembly drawing" not deleting the existing data of the designator layers!
Use our interactive Discord forum to reply or ask new questions.
Discord invite
Discord forum link (after invitation)

Didn't find what you were looking for?