Platform forum

Deleting component from the board.

hmoraghebi , 02-11-2021, 09:25 AM
I am new user of Altium and I am learning it using the FEDlevel training. I place a component on the board and then delete it. now when I try to place it on the board I do not see it. but if I try to place a new component it is possible. I wonder how I can place a component on a board when I have deleted it.

in case you use essential training I did the following
Lesson 4
  1. I followed your instruction to place the chip
  2. I placed the Resistance (R4) and capacitance (C7). I changed the DRC.
  3. I deleted the these and tried to place them again. I just wanted to practice again.
  4. Now when I click on R4 and then try to place on the board I cannot see anything. But if I try on another resistor, capacitor or any other component that I have not used I can place them on the board.
thanks so much in advance for your feedback.

thank you,

robertferanec , 02-15-2021, 01:07 AM
Please, can you add some screenshots?
przemek , 02-16-2021, 04:16 AM
I don't have access to this course, but I assume you have created both schematic and PCB? If so, if you remove a component from PCB and want to restore it, just go to schematic and transfer data from sch to PCB - menu Design - Update PCB Document.
robertferanec , 02-16-2021, 07:37 AM
@przemek I was not sure what @hmoraghebi meant by "I deleted these and tried to place them again.", but you may be right. Everything what @hmoraghebi may need is to sync schematic and PCB again. Thank you.
hmoraghebi , 02-16-2021, 07:34 PM
Hello Robert & Prezmek,
Thanks for your comment. Sorry for my late response. Below I have attached two snapshots:
1. The first image is when I try to place R3 on the board. I placed R3 on the board and then deleted it. Now it is the second time that I do it. I choose R3 then left click on the board, then right click and choose reposition. I do not see anything on the board.
2. The second image of component C3. This is the first time I try to place C3 on the board. I choose C3, left click on the board, Right click and choose Reposition. now I can see the component which I want to place.

Based on this images what do you think is the problem?
Maybe as you said I need to sync schematic and PCB again. Since I am new to Altium would you please let me know how I can do this.
Please let me know if you need any additional information.

thank you,
best Regards
przemek , 02-17-2021, 01:08 AM
So long time I had not been using this reposition command. Thanks for you screen shots, now it's easier to understand.

I read in Altium website that this command works as follows: you choose some components in the schematic, then launch reposition command in PCB and now you can move selected components one by one. More info here: https://www.altium.com/documentation...cecomponent-ad

But still this command is used to reposition, not to place components, right? So if I understand it correctly, it works for all the components that you had already placed in your board before using this command. And since you deleted R3 from PCB, then you cannot reposition it. First you need to place it again and then use reposition.

Please correct me if I'm wrong, but I've made a test schematic and PCB, transferred data from schematic to PCB and when the components are placed = I can use reposition command. When I remove on of them = I can't reposition that removed component.

For schematic and PCB sync, just do as I said in my previous post:
1. Go to schematic.
2. Menu Design - Update PCB.
3. Now ECO window should appear and just click on execute
robertferanec , 02-18-2021, 12:50 AM
I agree with @przemek. If you deleted the component from PCB, you will need to add it there again. Reposition component will not add the component, it will only select the component in PCB (so it has to exist there). As @przemek described, you can do synchronization, for example if you are in schematic use: Design -> Update PCB document.

PS: There is a simple way to see if the component is in PCB, you can use PCB panel:

hmoraghebi , 03-01-2021, 08:43 PM
Hello Robert,
Thanks so much for your and @@przemek help. I am sorry for my late response. Now it is working.

best Regards
Use our interactive Discord forum to reply or ask new questions.
Discord invite
Discord forum link (after invitation)

Didn't find what you were looking for?