Platform forum

Draftsman's isue!

JohnsonMiller , 10-22-2020, 12:29 PM
I was about to use the Draftsman output, I am using Win7. After creating initial empty sheets, and placing BoardAssembly view, it appear as blank, no component is visible! When I click to the blank area, invisible components get selected, so some data is there but not in the expected form. I have tried it with both AD17 and AD20/21, result is same!
On same Win7 and using a virtual machine I tried it with Win10, the Draftsman was working and output was as expected.
On same PC and a fresh Win10, again it was working. But moving back to Win7, fresh installation with all updates, result is no success!
My conclusion is that something is wrong with Win7, for some reasons I have to use Win7. I was checking with Altium website, Win7 is still supported by them.
Wondering have you seen such a issue? Since I am checking all on the same PC, my suggestion is that problem is related to OS.
Thanks for your help in advance.
WhoKnewKnows , 10-22-2020, 06:01 PM
I think in the properties of the draftsman item, you can select "snapshot of current 3d view" or some such. If this is selected, you may have to go look at the current 3d view. While looking, open the view configuration panel and switch to the tab that shows you the 3d controls and make sure the control that lets 3d components appear is enabled.
JohnsonMiller , 10-24-2020, 03:08 AM
@WhoKnewKnows , thank you for suggestion. I checked those points, but no success. The board 3D view is fine, problem is in the Draftsman side. Since same software without any setting works on Win10, there should be something wrong with the OS interface.
WhoKnewKnows , 10-24-2020, 05:30 AM
Perhaps the view is only obscured in the draftsman editor. Try converting to PDF or printing anyway. Maybe it will still give you what you want? 🤷
JohnsonMiller , 10-24-2020, 10:08 AM
@WhoKnewKnows ; your suggestion was correct, exporting to PDF I can see the result, at least.
Still question is there, why it is happening?
WhoKnewKnows , 10-24-2020, 03:22 PM
Seems to be a win 7 issue. It'll be difficult the get support on that from either Altium or Microsoft.
qdrives , 10-26-2020, 11:08 AM
Is it a problem with the graphics driver? Is it a WHQL certified one or perhaps a special for something like SolidWorks?
JohnsonMiller , 10-29-2020, 07:20 AM
@qdrives , FYI, I have tested the feature with the same release of AD under Win10 on the same PC, it was working; so it is not related to AD, something is wrong with graphic driver or Win7, itself. But strange is that generating PDF graphic shows up!
I have started this thread to check if someone had faced this issue and has a fix for it?
qdrives , 10-29-2020, 04:32 PM
@JohnsonMiller Faced similar issues - yes. Mostly over 10 years ago. With Alitum - could be, but I cannot recall any real situation.
Nowadays I occasionally see glitches, either low quality application but in most cases just bad driver / graphics card.
One test you may be able to do is to change the graphics driver to standard VGA. That would rule out Altium and/or Win7. I have done so in reverse, no driver for Win10 on an old laptop.
JohnsonMiller , 10-30-2020, 11:43 AM
@qdrives , your suggestion about WHQL seems correct. I tried to install a WHQL certified driver, but the g-card was not working and it was not helping. With a non-certified driver, the g-card is ok, but the draftsman issue is there.
I am using a virtual machine which Win10 and AD installed in it, when draftsman output is needed, I share the design with the virtual machine and create the output, this looks the best way, at least for now.
qdrives , 11-11-2020, 03:44 PM
How about an older driver?
Or as I said, use a plain standard VGA driver. I do not know if the 3D view will work then...
JohnsonMiller , 11-18-2020, 09:19 AM
Old driver works, but no with Craftsman!
I do not know how to use "use a plain standard VGA driver", can you give more detail?
qdrives , 11-20-2020, 12:01 PM
qdrives , 11-22-2020, 02:00 PM
@JohnsonMiller I just read the Altium release notes for AD 20.2.3:
38634Added "Draftsman.UI.SoftwareRender" option in the Advanced Settings dialog to use software rendering in Draftsman documents.
Perhaps that helps...
Use our interactive Discord forum to reply or ask new questions.
Discord invite
Discord forum link (after invitation)

Didn't find what you were looking for?