Platform forum

Reason for imx6q GPU hang ?

Kulunu , 07-26-2017, 12:58 AM
Hi All,
I encountered a problem with my iMX6Q custom hardware design with Linux version 4.1.15-1.0.0_ga+yocto+g76c24a0. System was stable 2 days and worked properly for long time. Suddenly I encountered following problem. I have an issue with GPU during I launch cameras (System stuck).

Camera launch >> gst-launch-1.0 v4l2src device=/dev/video0 ! autovideosink

Error message >> [galcore]: GPU[0] hang, automatic recovery.

As well as I could figure out following. I have done some testing to narrow down the issue.
I can get videos using imxg2dvideosink which uses 2D GPU without any conflict. But when run imxeglvivsink which uses 3D GPU the system gets GPU hang. So it seems like 3D GPU section has damaged. But the reason is this system performed well 2 days without any conflict.
Can we imagine some thing happened to 3D GPU section ? What can be the caus of this issue ? According to my knowledge this looks like hardware problem. Do I have any thing to do to clarify this problem ?


robertferanec , 07-26-2017, 10:31 AM
I would probably try Freescale/NXP/Qualcomm forum. That is very specific question.

What I would try ... maybe a different heatsink ... just to be sure the problem is not caused by overheating the board / chips. Also, if it's a custom hardware you need to be 100% sure, that memories were properly tested and are reliably working. Possibly, if you are still not sure, maybe try to run your whole system in an environmental chamber - if you will be able to repeat the problem.

It still can be a software problem (buffer leaking or something), but it can easily be hardware issue too.
Kulunu, 07-28-2017, 12:52 AM
Hi Robert,Many thanks !!How is it possible to work only 2D GPU ? If it is a power supply problem for GPU section the whole GPU shouldn't work. But here it just function 2D GPU and 3D GPU is not functioning. Whole the GPU section power up from VDD_PU_CAP internal regulator. In imx6q data sheet it is recommended to have 1.2V in VDD_PU_CAP. When I measure the voltage while the board is functioning it shows 1.12V. I doubt that. Is this the reason for this GPU hang when I'm using 3D GPU ? Any possibility with this low voltage for GPU hang ? Regards.Kulunu.
Use our interactive Discord forum to reply or ask new questions.
Discord invite
Discord forum link (after invitation)

Didn't find what you were looking for?