Platform forum

Altium Footprints

IMR , 05-22-2016, 11:52 PM

I've been using the (tools > new part) to create multiple schematic symbols for an FPGA, the problem is when I add the the footprint for the FPGA it adds the footprint to each sub part. For example if I divided an FPGA into 3 sub parts IC1A, IC1B and IC1C it adds 3 component footprints to the the PCB. How can I add the footprint in the schematic library without this happening?
mairomaster , 05-23-2016, 01:50 AM
That shouldn't be happening, maybe you are doing something wrong or have the wrong understanding of it. When you create the schematic symbol with sub-parts, it represents a single component. When you add it to the schematic, you should have the same designator number on all sub-parts - as you said IC1A, IC1B and IC1C for example. When you double click on one of the sub-parts, in the properties should say Part 1/3 for example (first part out of 3).
If all of this is correct, when you import the design to a PCB file, you will have 1 footprint representing the component with designator IC1.
IMR , 05-23-2016, 05:07 AM
I just tried deleting it and putting it back in and it worked, not sure how it happened but it seems to be fine now.
Use our interactive Discord forum to reply or ask new questions.
Discord invite
Discord forum link (after invitation)

Didn't find what you were looking for?