Platform forum

Net One Pin Error

ElDon , 05-16-2020, 10:35 PM
Hello, I've been following along with Robert's Altium tutorial for beginners on youtube and I'm having an issue where I'm getting an error stating nets only have one pin. I'm new PCB design and Altium so I'm kinda lost on where I messed up, so any help will be greatly appreciated 😅. Below is a picture of the schematic.

robertferanec , 05-18-2020, 03:27 AM
Try to double check pin orientation in your symbols. Only one end of the pin can be electrically connected.
ElDon , 05-20-2020, 11:02 PM
I doubled check that and my pins are in the right orientation.

robertferanec , 05-21-2020, 12:34 AM
Then, try to compile / validate your project (press right click on project name -> validate) and ten click on Panels -> Navigator and browse through the connections - that should give you an idea what exactly is not connected: https://youtu.be/Rfsq0EwJ5Xs
chitransh92 , 05-22-2020, 02:15 PM
Altium flags this error if it finds that there is only pin connected to particular Net.

This is nothing incorrect technically about your design since you will be using J1 to connect the +3.3V supply and you know that.
At times, when a big design is being worked up the designer forgets to add the nets to pins, where in this check of Altium really helps to identify the issue.

You are working on 20 page schematic and with a 1000 Pin FPGA pins.
On schematic Page 1 there is a output signal "Sig_A" which is supposed to trigger some circuit which is on schematic page 15.
While working you missed to connect the Input pin on page 15, During validation Altium will show this error and you can easily rectify that.

You can hide this error in Altium setting.
Refer : https://www.altium.com/documentation...nly-one-pin-ad

robertferanec , 05-23-2020, 12:40 AM
This is nothing incorrect technically about your design since you will be using J1 to connect the +3.3V supply and you know that.
- I believe, the error should not be there as in that schematic there are always two pins connected e.g. connector with resistor, resistor with diode, diode with connector. So first I thought maybe pins are rotated but it could be also off grid problem (looks like it is connected, but in reality it is not connected). If it is not pin rotation nor off grid problem ... then I am not sure ... that is why I suggested navigator, to check what it says.
chitransh92 , 05-23-2020, 03:58 AM
@robertferanec , You are absolutely right.
I tried this one out and there is no error for me..

Attached the screenshot for reference.

The image that @ElDon has attached in the first post shows in the bottom left cornor that it is one pin error..
This leaves to a combined conclusion of our understanding "may be" the Pin of the J1 are inverted.. :-)

Thank you.
robertferanec , 05-25-2020, 01:02 AM
I think pins of J1 are oki ... looks like pin name are inside of the connector, that should be fine. Let's see what @eidon will say what the problem was.
ElDon , 05-29-2020, 08:10 PM
Sorry for delayed response, but you were right @robertferanec I had a grid issue. I'm glad that I finally got this fixed thanks for the help too @chitransh92. 😁
Use our interactive Discord forum to reply or ask new questions.
Discord invite
Discord forum link (after invitation)

Didn't find what you were looking for?