Platform forum

Supplier links for multi-part component

angelsix , 09-16-2015, 02:00 AM
Not sure if you can help me on this one.
I have a microchip component that has 2 schematic parts. I added all the supplier properties from the supplier search and they show up in the schematic library for the part.

However, in the schematic itself, the part doesn’t show the properties, and neither does the bom.

robertferanec , 09-16-2015, 02:51 AM
@angelsix did you add the parameters after you placed the symbol into your schematic? Try to update it. First be sure, you saved and Compiled your library. For example, if you are using integrated library, go to "Projects" panel: Right click on the Integrated Library project -> Compile Integrated Library. Then go to your "SCH Library" panel: Right Click on the component -> Update Schematic Sheets. Please let me know if it helped.
angelsix , 09-16-2015, 03:02 AM
The libraries are both directly in the project as PcbLib and SchLib files. Save All was run, right clicked project and selected Compile ...PrjPcb, opened schematic library, right clicked and Update Schematic Sheets. Says nothing was updated.

I've, closed, reopened. Nothing fixed it.

That got me thinking though, so I updated the size of a pin legth and run the update. That didnt update either. So I just delete and readded the component from the schematic and dragged the component back on from the library and now it works.

It must of lost the link between the component on the schematic and in the library.
robertferanec , 09-16-2015, 03:08 AM
Great! @angelsix thank you very much for leaving your explanation how you fixed that.
Use our interactive Discord forum to reply or ask new questions.
Discord invite
Discord forum link (after invitation)

Didn't find what you were looking for?