Platform forum

Space bar doesn't rotate automatically

chris007 , 03-21-2016, 10:49 AM
I have a strange thing on Altium Designer.
When I am in PCB editor with a component selected , if I press Space Bar, normally it should rotate it automatically by 90°. However, here it ask me constantly how many degree I want to turn with a text box.
How do you make it automatic ?
mairomaster , 03-21-2016, 11:00 AM
Hi chris007,

That is really strange. Although that could not cause the same problem in my Altium 16, just in case check your setting in DXP -> Preferences -> PCB Editor -> General -> Rotation step. No matter how I set it, it seems to work fine with me though. Of course if it is set to 0, it doesn't rotate at all.
chris007 , 03-21-2016, 12:04 PM
Thank you for replying.
Yes very strange. I have taken screenshot of my prferences.
Can you check in your Shortkey command if your space bar is allocated to rotate function and if yes how ?
The space bar rotate properly components in SCHEMATIC but not in PCB.
chris007 , 03-21-2016, 12:36 PM
I find out also some hotkey are not working in PCB Editor. For example normally to flip a component on the other side of the pcb the hoteky is L . If I type L on PCB editor it open me some stack windows
chris007 , 03-21-2016, 12:45 PM
Another strange things I find out is if I click with left click on a component and hold this click then press space bar, it open the pop up for me to input data of angle to rotate, if then hit Escape, then the pop up close and the component turn 90° by itself
mairomaster , 03-21-2016, 01:02 PM
Ok another idea. Check if you are using the default key mapping in View -> Key Mappings. Which version of Altium are you using? Maybe you can try to reset to default settings, if you don't have many custom ones.
robertferanec , 03-21-2016, 01:20 PM
@chris007, did you try switch off / on Altium? It sometimes helps.
chris007 , 03-21-2016, 11:20 PM
The Key mappings is set to Default, the altium version I am using is 14.3.9. i have already try to reset the default in the DXP Preference PCb Editor with no success.
I have already tried to closed altium and reopen it, I have even tried to open a new project. With no success
robertferanec , 03-22-2016, 03:00 AM
If Altium switch off/on didn't help, and if PC reset didn't help, I would probably reinstall Altium and I would not import parameters and settings. It looks like there is something weird with the Altium. I have seen similar behavior before (mostly after Altium crash message), but ON/OFF usually helps.
chris007 , 03-22-2016, 06:29 AM
I have tried already to close and open again. Either the space bar doesn't do anything on PCB editor or if I allocate via shortkey command it will prompt me for the value...
robertferanec, 03-22-2016, 06:37 AM
I had exactly the same issue once (space-bar didn't work in PCB), but I do not remember how I fixed it. Maybe before you re-install, try to install latest update for your Altium version.
chris007 , 03-22-2016, 06:52 AM
This is very weird because there are several keys which are not working as indicated in the short key manual of altium. The L for example should place the component on the other side of the pcb, but instead it open the view configuration, to make the L to work properly I have to go myself in the command configuration and to allocate the L to the flip. I can allocate the rotate to Space bar, the problem is it prompt me every time with value...
robertferanec, 03-22-2016, 07:03 AM
It should not work that way. I believe, there really may be something broken in the Altium on your computer and the safe way to fix it will be re-install it or install a new version.
chris007 , 03-22-2016, 09:12 PM
Another guy on stackexchange forum gave me the solution : The component has to be clicked and hold with left click, then press space bar and it rotate ...
mairomaster , 03-23-2016, 01:55 AM
Yeah, as it often happens the simplest thing is the answer... I thought to suggest that, but I tried it in Altium and even with just selected component, I wasn't getting such popup as you.
robertferanec , 03-23-2016, 02:09 AM
Ah , I understand now Yep, you need to "hold" the component. I didn't notice that in your first post and I almost convinced you to re-install Altium
Use our interactive Discord forum to reply or ask new questions.
Discord invite
Discord forum link (after invitation)

Didn't find what you were looking for?