Platform forum

About short circuit between objects with same net name

mulfycrowh , 01-04-2023, 09:24 AM
Hi everyone,

That's weird.
I have 3 objects: pad, track and via with same net names.
AD declares a short circuit between them.
How is it possible?

WhoKnewKnows , 01-04-2023, 11:13 AM
Happy New Year, All.

@mulfycrowh the screenshot appears to show a bottom layer pad and track and a via. Could there be an object on another layer that's not visible in the screenshot, but is in conflict with the via and bottom layer objects?
mulfycrowh , 01-04-2023, 11:24 AM
@WhoKnewKnows I have to explain what I did.
It is an update of a design with 0 errors.
To chose between HDMI and DP configuration, I have introduced 4 jumpers on a differential pair.
Before I had 2 resistors and I decided to replace one resistor with a capacitor.
I left the name of the differential pairs unchanged.

I have got a very weird error.
I managed to get rid of the errors by moving a little bit the via to the right side.
But as I want to route the differential pair on an internal layer, AD says it can't be found the second pair primitive.

There is nothing disturbing on the other layers.
I really don't know what happened.

WhoKnewKnows , 01-04-2023, 11:27 AM
BT Dubs, usually the short circuit error message includes info about which nodes Altium thinks are shorted together. You might try using node highlighting on the various nodes Altium claims are shorted together to see if you can see if you can see where the claimed short circuit exists 🤷
mulfycrowh , 01-04-2023, 11:38 AM
Ant it is the same problem on the load.
So I think that the issue comes from the differential pair but I don't see where.
mulfycrowh , 01-04-2023, 11:45 AM
The differential pair is routed on the yellow layer.
I cut both ends of it on source and load sides, just to understand the issue.
As you can see, the differential pair is also on warning!
mulfycrowh , 01-04-2023, 11:47 AM
I have 4 differential pairs.
I managed the first one without any problem.
You can see it on the yellow layer.
mulfycrowh , 01-04-2023, 12:18 PM
Please find the schematic below
qdrives , 01-04-2023, 01:10 PM
If you select a track, pad or via, then press the tab key twice to select all attached copper, and then in the properties panel assign/select the net.
I had similar issues when I changed the nets in schematic and Altium did not properly convert a tiny track element.
A hint that this is the case is when Altium does not show a net name when all connected copper is selected.
mulfycrowh , 01-04-2023, 01:41 PM
@WhoKnewKnowsI tried what you said on the via, blue track and pad for _N and _P.
The problem is that I cannot route from the via: AD doesn't find the second primitive of the pair.
As shown on the attached screenshot, the issue is bound to C_DDI1_2HP1 and C_DDI1_2HP3.
mulfycrowh , 01-04-2023, 01:46 PM
Maybe that's an important information: regarding to the differential pairs that are bound to the problem, the involved vias lost their net names just after the import
mulfycrowh , 01-04-2023, 03:39 PM
Whatever the object I click on with the net name C_DDI1_2HP1_N (or _P) or C_DDI1_2HP3_N (or _P), AD doesn't find the second differential pair primitive.
I really don't understand.
WhoKnewKnows , 01-05-2023, 09:13 AM
Whenever I'm truly stuck like this, I create an entirely new design that replicates all of the conditions of the stuck design so I can share the issue I'm having while obfuscating the true nature of the entire design. Often, in the process of building up this "test case" I discover what is wrong before I even have to share it. Hope this helps. 🤷‍♂️
mulfycrowh , 01-05-2023, 09:48 AM
@WhoKnewKnowsI fixed the issue and I have no clear idea how I did it.
I cleaned everything on the nets on the involved differential pairs.
I notice that AD very often created unaffected chunks of tracks. Especially under the vias.
Maybe it is a reason but for me it doesn't explain why it was not possible to route the differential pairs (AD didn't find the second differential pair primitive).

That's what we call a big big bug!
robertferanec , 01-10-2023, 09:04 AM
Great you fixed it. PS: Sometimes helps to clear all DRC errors (Tools -> Reset Error Markers) and run DRC again.
Use our interactive Discord forum to reply or ask new questions.
Discord invite
Discord forum link (after invitation)

Didn't find what you were looking for?