Platform forum


Nguyenvanhieu , 10-11-2016, 09:41 PM
When using variant,i have 2 component xtal 8 Mhz and 16 Mhz ,exactly the same manufacture partnumber,sch in sch library(copy and paste) and footprint.But when choose each variant,the component dont compatible.What should I do to fix it?Thank you
robertferanec , 10-12-2016, 06:16 AM
Can you attach your project? There is probably a difference. Double check symbols, it's pin numbers and names.
Nguyenvanhieu , 10-12-2016, 11:34 PM
Everything is ok.Pin numbers and names in library are the same,I double check it.But when choose different variant in schematic,component automatically moves away to Net.Thats I dont know why.
mairomaster , 10-13-2016, 02:16 AM
Are you sure you are using exactly the same symbol for the two components? To me it seems like one of the symbols has different position according to the origin in the library.
Nguyenvanhieu , 10-13-2016, 07:41 AM
No.They are same.I moved them to the origin.
robertferanec , 10-14-2016, 06:44 AM
Hello @Nguyenvanhieu, please, could you attach your project? That would be easier to figure out.
Nguyenvanhieu , 10-14-2016, 09:07 AM
Here is my project
Nguyenvanhieu , 10-14-2016, 09:10 AM
robertferanec , 10-16-2016, 08:49 AM
@Nguyenvanhieu, it worked for me ok:

robertferanec , 10-16-2016, 08:52 AM
Maybe just try to delete the component and place it again, maybe it will help you? I have done nothing, it just worked, but you didn't send me your project (only schematic and library), so I had to create the project by myself and can be different from yours. Also, some Altium versions had bugs in Variants ... what Altium version do you use? I used AD16.
Nguyenvanhieu , 10-16-2016, 08:56 AM
Oh,Really? I think its not big issue although doesn't look like.I will use variant in other project and see if this problem happens again,I will tell you know
Nguyenvanhieu , 10-16-2016, 08:58 AM
I use altium 15.
robertferanec , 10-16-2016, 09:21 AM
Oki, please let me know then.
Nguyenvanhieu , 10-16-2016, 10:04 AM
Hi @robertferanec For easier,I uploaded my project to googledrive.You can follow this link https://drive.google.com/drive/my-drive to see what really problem.
And after fixed it, please,take 5 minutes to see my pcb,give me some note for something need to be improved. Its very important to me at this time.5 mins=big encouragement.
mairomaster , 10-17-2016, 02:01 AM
I was curious to check the project as well, but your link doesn't seem to work. It takes me to my personal google drive.
robertferanec, 10-17-2016, 06:43 AM
Yes me too. Nguyenvanhieu sent me the file by mail.
robertferanec , 10-17-2016, 07:23 AM
@Nguyenvanhieu your 8MHz crystal definition is wrong in the library, it has two footprints:

robertferanec , 10-17-2016, 07:43 AM
But there is still something weird in schematic / project / Variant / Altium. The crystals keep moving between variants (re-position themselves). I do not really know why (even if I replace the crystal for itself in the variant, it still will move .... watch how I switch from variant 5V to 5V/3V3)

Nguyenvanhieu , 10-17-2016, 09:10 AM
So,@robertferanec ,How can I fix it?
Nguyenvanhieu , 10-17-2016, 09:12 AM
Sorry @maicromaster,please send me your email.I will share my drive
robertferanec , 10-18-2016, 07:20 AM
So,@robertferanec ,How can I fix it?
@Nguyenvanhieu, hmm, I played with your project for some time, but I do not know what the problem is. Maybe, first, test if the problem is in the library or project. For example, try to use the library with a new project and see if behavior is same. Possibly, try to create new crystals in library (create them from scratch) and see if you use them in your project, if the behavior is same.

Please, when you come up with a solution, let me know. I really would like to know what the problem is - it's really weird.
Use our interactive Discord forum to reply or ask new questions.
Discord invite
Discord forum link (after invitation)

Didn't find what you were looking for?